package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<link.*href=['"]([^'"]*).*|<script.*src=['"]([^'"]*).*)`)
var str = `<link rel="stylesheet" type="text/css" href="/BLAH/Test/Test/Test.css">
<script src="/blah/Test/Test/Test.js"></script>
<link href="/BLAH/Test/Test/Test.css" xx="dfasf">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}