import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<link.*href=['\"]([^'\"]*).*|<script.*src=['\"]([^'\"]*).*)";
final String string = "<link rel=\"stylesheet\" type=\"text/css\" href=\"/BLAH/Test/Test/Test.css\">\n"
+ "<script src=\"/blah/Test/Test/Test.js\"></script> \n"
+ "<link href=\"/BLAH/Test/Test/Test.css\" xx=\"dfasf\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}