// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<link.*href=['"]([^'"]*).*|<script.*src=['"]([^'"]*).*)"#).unwrap();
let string = "<link rel=\"stylesheet\" type=\"text/css\" href=\"/BLAH/Test/Test/Test.css\">
<script src=\"/blah/Test/Test/Test.js\"></script>
<link href=\"/BLAH/Test/Test/Test.css\" xx=\"dfasf\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}