using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<link.*href=['""]([^'""]*).*|<script.*src=['""]([^'""]*).*)";
string input = @"<link rel=""stylesheet"" type=""text/css"" href=""/BLAH/Test/Test/Test.css"">
<script src=""/blah/Test/Test/Test.js""></script>
<link href=""/BLAH/Test/Test/Test.css"" xx=""dfasf"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}