re = /(<link.*href=['"]([^'"]*).*|<script.*src=['"]([^'"]*).*)/m
str = '<link rel="stylesheet" type="text/css" href="/BLAH/Test/Test/Test.css">
<script src="/blah/Test/Test/Test.js"></script>
<link href="/BLAH/Test/Test/Test.css" xx="dfasf">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end