$re = '/(<link.*href=[\'"]([^\'"]*).*|<script.*src=[\'"]([^\'"]*).*)/m';
$str = '<link rel="stylesheet" type="text/css" href="/BLAH/Test/Test/Test.css">
<script src="/blah/Test/Test/Test.js"></script>
<link href="/BLAH/Test/Test/Test.css" xx="dfasf">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);