#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n\d+\.[^\S\r\n]+(.+)"
Local $sString = "" & @CRLF & _
"1. foo" & @CRLF & _
"2. bar" & @CRLF & _
"3. foobar" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1. foo." & @CRLF & _
"" & @CRLF & _
"2. bar." & @CRLF & _
"" & @CRLF & _
"3. foobar."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")