re = /\n\d+\.[^\S\r\n]+(.+)/m
str = '
1. foo
2. bar
3. foobar
1. foo.
2. bar.
3. foobar.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end