// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\n\d+\.[^\S\r\n]+(.+)").unwrap();
let string = "
1. foo
2. bar
3. foobar
1. foo.
2. bar.
3. foobar.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}