package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n\d+\.[^\S\r\n]+(.+)`)
var str = `
1. foo
2. bar
3. foobar
1. foo.
2. bar.
3. foobar.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}