const regex = /\n\d+\.[^\S\r\n]+(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n\\d+\\.[^\\S\\r\\n]+(.+)', 'gm')
const str = `
1. foo
2. bar
3. foobar
1. foo.
2. bar.
3. foobar.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}