using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n\d+\.[^\S\r\n]+(.+)";
string input = @"
1. foo
2. bar
3. foobar
1. foo.
2. bar.
3. foobar.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}