$re = '/\n\d+\.[^\S\r\n]+(.+)/m';
$str = '
1. foo
2. bar
3. foobar
1. foo.
2. bar.
3. foobar.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);