import re
regex = re.compile(r"\b\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}", flags=re.MULTILINE)
test_str = ("127.0.0.1\n"
"a.b.c.d\n"
"127 0 0 1\n"
"251.147.187.212\n"
"174.238.178.106\n"
"186 40 44 191\n"
"127..0.0.1\n"
"127 0 0 1\n"
"127. 0 0 1\n"
"127. .. 0 .. . 0. . .1\n"
"127001\n"
"183.... 183.... 183.... 183d\n"
"127.0.0.1\n"
"127.\n"
"0.\n"
"0.\n"
"1\n"
"1111.1.1.1\n"
"1\n"
"127.0.0.1 \n"
"1\n"
"1\n"
"1\n"
"1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")