// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}").unwrap();
let string = "127.0.0.1
a.b.c.d
127 0 0 1
251.147.187.212
174.238.178.106
186 40 44 191
127..0.0.1
127 0 0 1
127. 0 0 1
127. .. 0 .. . 0. . .1
127001
183.... 183.... 183.... 183d
127.0.0.1
127.
0.
0.
1
1111.1.1.1
1
127.0.0.1
1
1
1
1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}