re = /\b\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}/m
str = '127.0.0.1
a.b.c.d
127 0 0 1
251.147.187.212
174.238.178.106
186 40 44 191
127..0.0.1
127 0 0 1
127. 0 0 1
127. .. 0 .. . 0. . .1
127001
183.... 183.... 183.... 183d
127.0.0.1
127.
0.
0.
1
1111.1.1.1
1
127.0.0.1
1
1
1
1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end