using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:Chain ([\d]).*{)((((?:\w+\s*)+):([\d.-]+)C )+)";
string input = @"Chain 1 --> {PCB Temp A:22C B:22C C:24C Catalina Temp:12C }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}