$re = '/(?:Chain ([\d]).*{)((((?:\w+\s*)+):([\d.-]+)C )+)/m';
$str = 'Chain 1 --> {PCB Temp A:22C B:22C C:24C Catalina Temp:12C }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);