package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:Chain ([\d]).*{)((((?:\w+\s*)+):([\d.-]+)C )+)`)
var str = `Chain 1 --> {PCB Temp A:22C B:22C C:24C Catalina Temp:12C }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}