import re
regex = re.compile(r"(?:Chain ([\d]).*{)((((?:\w+\s*)+):([\d.-]+)C )+)", flags=re.MULTILINE)
test_str = "Chain 1 --> {PCB Temp A:22C B:22C C:24C Catalina Temp:12C }"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")