#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\x{0030}-\x{0039}]+|[\x{0660}-\x{0669}]+)$"
Local $sString = "#YES" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"8" & @CRLF & _
"9" & @CRLF & _
"٠" & @CRLF & _
"١" & @CRLF & _
"١٠" & @CRLF & _
"432" & @CRLF & _
"34" & @CRLF & _
"" & @CRLF & _
"#Not sure, mixing two sets" & @CRLF & _
"1٠2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#NO" & @CRLF & _
"1a" & @CRLF & _
"s" & @CRLF & _
"s324"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")