using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\x{0030}-\x{0039}]+|[\x{0660}-\x{0669}]+)$";
string input = @"#YES
0
1
2
3
4
5
6
7
8
9
٠
١
١٠
432
34
#Not sure, mixing two sets
1٠2
#NO
1a
s
s324";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}