import re
regex = re.compile(r"^([\x{0030}-\x{0039}]+|[\x{0660}-\x{0669}]+)$", flags=re.MULTILINE)
test_str = ("#YES\n"
"0\n"
"1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"7\n"
"8\n"
"9\n"
"٠\n"
"١\n"
"١٠\n"
"432\n"
"34\n\n"
"#Not sure, mixing two sets\n"
"1٠2\n\n\n"
"#NO\n"
"1a\n"
"s\n"
"s324")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")