import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\x{0030}-\\x{0039}]+|[\\x{0660}-\\x{0669}]+)$";
final String string = "#YES\n"
+ "0\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "5\n"
+ "6\n"
+ "7\n"
+ "8\n"
+ "9\n"
+ "٠\n"
+ "١\n"
+ "١٠\n"
+ "432\n"
+ "34\n\n"
+ "#Not sure, mixing two sets\n"
+ "1٠2\n\n\n"
+ "#NO\n"
+ "1a\n"
+ "s\n"
+ "s324";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}