const regex = /^([\x{0030}-\x{0039}]+|[\x{0660}-\x{0669}]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\x{0030}-\\x{0039}]+|[\\x{0660}-\\x{0669}]+)$', 'gm')
const str = `#YES
0
1
2
3
4
5
6
7
8
9
٠
١
١٠
432
34
#Not sure, mixing two sets
1٠2
#NO
1a
s
s324`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}