// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\x{0030}-\x{0039}]+|[\x{0660}-\x{0669}]+)$").unwrap();
let string = "#YES
0
1
2
3
4
5
6
7
8
9
٠
١
١٠
432
34
#Not sure, mixing two sets
1٠2
#NO
1a
s
s324";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}