using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\n\n+\s+}|\n\n})";
string substitution = @"\n}";
string input = @"------------------------------------------------------------------------------
REGEX to strip all whitelines ABOVE line with single closing curly bracket
------------------------------------------------------------------------------
```powershell
Describe {
Write-Host ""As happening with InModuleScope.mdx""
It ""Test Export-CSV"" {
Get-ChildItem | Export-CSV -Path $filePath -NoTypeInformation
$dir = Import-CSV -Path $filePath
# ...
}
It ""Test Export-Clixml"" {
Get-ChildItem | Export-Clixml -Path $filePath
$dir = Import-Clixml -Path $filePath
# ...
}
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}