const regex = /(\n\n+\s+}|\n\n})/mgs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\n\\n+\\s+}|\\n\\n})', 'mgs')
const str = `------------------------------------------------------------------------------
REGEX to strip all whitelines ABOVE line with single closing curly bracket
------------------------------------------------------------------------------
\`\`\`powershell
Describe {
Write-Host "As happening with InModuleScope.mdx"
It "Test Export-CSV" {
Get-ChildItem | Export-CSV -Path \$filePath -NoTypeInformation
\$dir = Import-CSV -Path \$filePath
# ...
}
It "Test Export-Clixml" {
Get-ChildItem | Export-Clixml -Path \$filePath
\$dir = Import-Clixml -Path \$filePath
# ...
}
`;
const subst = `\n}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);