import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\n\\n+\\s+\\}|\\n\\n\\})";
final String string = "------------------------------------------------------------------------------\n"
+ "REGEX to strip all whitelines ABOVE line with single closing curly bracket\n"
+ "------------------------------------------------------------------------------\n\n"
+ "```powershell\n"
+ "Describe {\n"
+ " Write-Host \"As happening with InModuleScope.mdx\"\n\n"
+ " It \"Test Export-CSV\" {\n"
+ " Get-ChildItem | Export-CSV -Path $filePath -NoTypeInformation\n"
+ " $dir = Import-CSV -Path $filePath\n"
+ " # ...\n\n\n\n"
+ "}\n"
+ " It \"Test Export-Clixml\" {\n"
+ " Get-ChildItem | Export-Clixml -Path $filePath\n"
+ " $dir = Import-Clixml -Path $filePath\n"
+ " # ...\n\n"
+ " }\n\n";
final String subst = "\\n}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}