# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[name:([A-Z]+)\]\[distance:(\d+)\]/[$1:$2]/g;t' <<< "City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:"