const regex = /\[name:([A-Z]+)\]\[distance:(\d+)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[name:([A-Z]+)\\]\\[distance:(\\d+)\\]', 'g')
const str = `City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:`;
const subst = `[$1:$2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);