re = /\[name:([A-Z]+)\]\[distance:(\d+)\]/
str = 'City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:'
subst = '[$1:$2]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result