// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[name:([A-Z]+)\]\[distance:(\d+)\]").unwrap();
let string = "City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:";
let substitution = "[$1:$2]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}