using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[name:([A-Z]+)\]\[distance:(\d+)\]";
string substitution = @"[$1:$2]";
string input = @"City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}