#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[name:([A-Z]+)\]\[distance:(\d+)\]"
Local $sString = "City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:"
Local $sSubst = "[$1:$2]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)