$re = '/\[name:([A-Z]+)\]\[distance:(\d+)\]/';
$str = 'City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:';
$subst = "[$1:$2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;