# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*<(\d+(?:\.\d+)?).*/\1/gm;t' <<< "7.20-<7.35
25-<32
60-<83e
40-<50
0.85-<1.15
80-<98
3.0-<3.4
NA
3.0-<3.4 (110)"