package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*<(\d+(?:\.\d+)?).*`)
var str = `7.20-<7.35
25-<32
60-<83e
40-<50
0.85-<1.15
80-<98
3.0-<3.4
NA
3.0-<3.4 (110)`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}