use strict;
my $str = '7.20-<7.35
25-<32
60-<83e
40-<50
0.85-<1.15
80-<98
3.0-<3.4
NA
3.0-<3.4 (110)';
my $regex = qr/.*<(\d+(?:\.\d+)?).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";