import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*<(\\d+(?:\\.\\d+)?).*";
final String string = "7.20-<7.35\n"
+ "25-<32\n"
+ "60-<83e\n"
+ "40-<50\n"
+ "0.85-<1.15\n"
+ "80-<98\n"
+ "3.0-<3.4\n"
+ "NA\n"
+ "3.0-<3.4 (110)";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}