re = /.*<(\d+(?:\.\d+)?).*/m
str = '7.20-<7.35
25-<32
60-<83e
40-<50
0.85-<1.15
80-<98
3.0-<3.4
NA
3.0-<3.4 (110)'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result