# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/image(\d)$/image00$1/gm;t' <<< "image1
image2
image3
image4
image5
image6
image7
image8
image9
image10
image11
image12
image13
image14
image15
image100
image101
image102
image103
image104
image105"