re = /image(\d)$/m
str = 'image1
image2
image3
image4
image5
image6
image7
image8
image9
image10
image11
image12
image13
image14
image15
image100
image101
image102
image103
image104
image105'
subst = 'image00$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result