using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"image(\d)$";
string substitution = @"image00$1";
string input = @"image1
image2
image3
image4
image5
image6
image7
image8
image9
image10
image11
image12
image13
image14
image15
image100
image101
image102
image103
image104
image105";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}