# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"image(\d)$"
test_str = ("image1\n"
"image2\n"
"image3\n"
"image4\n"
"image5\n"
"image6\n"
"image7\n"
"image8\n"
"image9\n"
"image10\n"
"image11\n"
"image12\n"
"image13\n"
"image14\n"
"image15\n"
"image100\n"
"image101\n"
"image102\n"
"image103\n"
"image104\n"
"image105")
subst = "image00$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.