// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)image(\d)$").unwrap();
let string = "image1
image2
image3
image4
image5
image6
image7
image8
image9
image10
image11
image12
image13
image14
image15
image100
image101
image102
image103
image104
image105";
let substitution = "image00$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}