const regex = /image(\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('image(\\d)$', 'gm')
const str = `image1
image2
image3
image4
image5
image6
image7
image8
image9
image10
image11
image12
image13
image14
image15
image100
image101
image102
image103
image104
image105`;
const subst = `image00$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);