#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<p class="text_obisnuit">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)"
Local $sString = "<p class="text_obisnuit"><em>I have to make sure of that</em></p>" & @CRLF & _
"" & @CRLF & _
"<p class="text_obisnuit"><em>I have to make sure of that</em><br>" & @CRLF & _
"<p class="text_obisnuit">I have to make sure of that</div>" & @CRLF & _
"<p class="text_obisnuit">I have to make sure of that" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"Toto, I have to select all lines that do not end with </p>" & @CRLF & _
"" & @CRLF & _
"your regex <p class="TEXT">(?:(?!<br>)(?!<p).)*(?:<.+?>|\z)" & @CRLF & _
"" & @CRLF & _
"becomes in this case:" & @CRLF & _
"" & @CRLF & _
"<p class="text_obisnuit">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)" & @CRLF & _
"" & @CRLF & _
"I think I made a mistake somewhere"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")