import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p class=\"text_obisnuit\">(?:(?!<\\/p>)(?!<p).)*(?:<.+?>|\\z)";
final String string = "<p class=\"text_obisnuit\"><em>I have to make sure of that</em></p>\n\n"
+ "<p class=\"text_obisnuit\"><em>I have to make sure of that</em><br>\n"
+ "<p class=\"text_obisnuit\">I have to make sure of that</div>\n"
+ "<p class=\"text_obisnuit\">I have to make sure of that\n"
+ "</div>\n\n"
+ "Toto, I have to select all lines that do not end with </p>\n\n"
+ "your regex <p class=\"TEXT\">(?:(?!<br>)(?!<p).)*(?:<.+?>|\\z)\n\n"
+ "becomes in this case:\n\n"
+ "<p class=\"text_obisnuit\">(?:(?!<\\/p>)(?!<p).)*(?:<.+?>|\\z)\n\n"
+ "I think I made a mistake somewhere";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}