use strict;
my $str = '<p class="text_obisnuit"><em>I have to make sure of that</em></p>
<p class="text_obisnuit"><em>I have to make sure of that</em><br>
<p class="text_obisnuit">I have to make sure of that</div>
<p class="text_obisnuit">I have to make sure of that
</div>
Toto, I have to select all lines that do not end with </p>
your regex <p class="TEXT">(?:(?!<br>)(?!<p).)*(?:<.+?>|\\z)
becomes in this case:
<p class="text_obisnuit">(?:(?!<\\/p>)(?!<p).)*(?:<.+?>|\\z)
I think I made a mistake somewhere';
my $regex = qr/<p class="text_obisnuit">(?:(?!<\/p>)(?!<p).)*(?:<.+?>|\z)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}